Repository navigation
Full table scan of default partition during partman maintenance (ATTACH PARTITION) #877
sanjay-motorq
started this conversation in
General
Replies: 0 comments
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
Problem: We have a usecase where we partition our tables by timestamp and there are cases where data can arrive late. This data, if it lies outside the range of our partitions will go to the default partition. We cannot afford to drop this data immediately or change the partition key.
We have a way to clean up the default partition once the data is no longer required.
The issue here is that, partman maintenance takes too long due to the amount of data in default partition. Since this locks the table, our queries fail during this time window.
Proposal: If the goal is to check the default table for any conflicting rows (that might belong in the new partition), why cant we use an index scan instead of a full table scan ?
What are the blockers to go with this approach ?
All reactions