Skip to content

Setting ip-address to Private causes an error #53

Description

Setting below

    - name: 'Deploy'
      uses: azure/aci-deploy@v1
      with:
        resource-group: ${{ secrets.AZURE_RESOURCE_GROUP }}
        registry-login-server: ${{ secrets.AZURE_REGISTRY_LOGIN_SERVER }}
        registry-username: ${{ secrets.AZURE_REGISTRY_USERNAME }}
        registry-password: ${{ secrets.AZURE_REGISTRY_PASSWORD }}
        name: $DEPLOYMENT_NAME
        image: $IMAGE:$GITHUB_SHA
        location: 'south central us'
        os-type: Windows
        cpu: 4
        memory: 16
        environment-variables: DOTNET_ENVIRONMENT=Production
        restart-policy: OnFailure
        dns-name-label: $DEPLOYMENT_NAME
        ip-address: Private

throws the error below

Error: DNS name label for container group is only supported when IP Address type is public.

and removing dns-name-label throws the error below

Error: Input required and not supplied: dns-name-label

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions